summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89b5cf11de47..5d61553d1b58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Contributor: Ordoban <dirk.langer@vvovgonik.de>
pkgname='perl-moosex-methodattributes'
-pkgver='0.31'
-pkgrel='2'
+pkgver='0.32'
+pkgrel='3'
pkgdesc="code attribute introspection"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl-moose>=0.98' 'perl-moosex-types' 'perl-namespace-clean>=0.10')
makedepends=('perl-namespace-autoclean' 'perl-test-exception' 'perl-test-checkdeps')
-url='http://search.cpan.org/dist/MooseX-MethodAttributes'
-source=("http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/MooseX-MethodAttributes-$pkgver.tar.gz")
-md5sums=('fa9202b179c438844c3bea2ca7ecfe9d')
+url='https://metacpan.org/release/MooseX-MethodAttributes'
+source=("https://cpan.metacpan.org/authors/id/E/ET/ETHER/MooseX-MethodAttributes-$pkgver.tar.gz")
+md5sums=('f18009f821e62b3fd9c2605820a0e61b')
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
PERL_AUTOINSTALL=--skipdeps \
PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
@@ -23,14 +23,12 @@ build() {
cd "${srcdir}/MooseX-MethodAttributes-$pkgver"
/usr/bin/perl Makefile.PL
make
- )
}
check() {
cd "${srcdir}/MooseX-MethodAttributes-$pkgver"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="."
+ make test
}
package() {