summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b5795265f51..dcd74a83883b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Generator : CPANPLUS::Dist::Arch 1.28
pkgname='perl-net-curl'
-pkgver='0.51'
+pkgver='0.54'
pkgrel='1'
pkgdesc="Perl interface for libcurl"
arch=('i686' 'x86_64')
@@ -12,10 +12,16 @@ options=('!emptydirs')
depends=('curl>=7.37.0' 'perl')
makedepends=('gcc')
url='http://search.mcpan.org/dist/Net-Curl'
-source=("http://search.mcpan.org/CPAN/authors/id/S/SY/SYP/Net-Curl-${pkgver}.tar.gz")
-sha256sums=('1e8582d6f1cf1382443765b20976f6e799a2f51eb790c203752be2851682d86c')
+source=("http://search.mcpan.org/CPAN/authors/id/S/SY/SYP/Net-Curl-${pkgver}.tar.gz" "0001-fix-test-13-when-running-curl-8.2.patch")
+sha256sums=('ad76bd1bf97d61bbd758a196e945c232d1cb7b2064e751f6c88c344086d6ffbc'
+ '1d9f9af639c973f565a2f31d0ba98103a9756b588421da3961921570e57076c9')
_distdir="Net-Curl-${pkgver}"
+prepare() {
+ cd "$srcdir/$_distdir"
+ patch --strip=1 --input="$srcdir/0001-fix-test-13-when-running-curl-8.2.patch"
+}
+
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
PERL_AUTOINSTALL=--skipdeps \