summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40c58200cffb..1fca1d127841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_author=TOMHRR
_perlmod=Net-IP-XS
pkgname=perl-net-ip-xs
-pkgver=0.15
+pkgver=0.16
pkgrel=1
pkgdesc="XS implementation of Net::IP"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0' 'perl-tie-simple' 'perl-math-bigint' 'perl-ip-country' 'perl-io-capture')
options=(!emptydirs)
source=(http://cpan.perl.org/modules/by-authors/id/${_author:0:1}/${_author:0:2}/$_author/$_perlmod-$pkgver.tar.gz)
-md5sums=('c54615bcfe14306b8e125529f93baefd')
+md5sums=('01e9e5be15b2a643274aadbc1269cbfe')
build() {
cd "$srcdir/$_perlmod-$pkgver"
@@ -22,6 +22,12 @@ build() {
}
+check() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make test
+
+}
+
package() {
cd "$srcdir/$_perlmod-$pkgver"
make install DESTDIR="$pkgdir/"