summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ca416f53a32..7871d0c35d28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# CPAN Name : WWW::Shorten
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.30
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-www-shorten
-pkgver=3.06
+pkgver=3.093
pkgrel=1
pkgdesc='Interface to URL shortening sites'
arch=('any')
url='https://metacpan.org/release/WWW-Shorten'
license=('PerlArtistic' 'GPL')
-depends=('perl' 'perl-libwww')
+depends=('perl-libwww' 'perl-try-tiny')
optdepends=('perl-config-auto: for configuration file support')
-source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.06.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/C/CA/CAPOEIRAB/WWW-Shorten-3.093.tar.gz)
options=(!emptydirs)
-md5sums=('7fec4441d031973710ee61999f964bd2')
+md5sums=('44bfbdd42ed459bf1e87291202ed35cf')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -21,20 +21,20 @@ sanitize() {
}
build() {
- cd WWW-Shorten-3.06
+ cd WWW-Shorten-3.093
sanitize
/usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd WWW-Shorten-3.06
+ cd WWW-Shorten-3.093
sanitize
make test
}
package() {
- cd WWW-Shorten-3.06
+ cd WWW-Shorten-3.093
sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete