summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ef4fe586fcf..9ca416f53a32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
# CPAN Name : WWW::Shorten
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.29
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-www-shorten
-pkgver=3.05
+pkgver=3.06
pkgrel=1
pkgdesc='Interface to URL shortening sites'
arch=('any')
-url='http://search.cpan.org/dist/WWW-Shorten'
+url='https://metacpan.org/release/WWW-Shorten'
license=('PerlArtistic' 'GPL')
depends=('perl' 'perl-libwww')
optdepends=('perl-config-auto: for configuration file support')
-source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.05.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.06.tar.gz)
options=(!emptydirs)
-md5sums=('bdc5be1fac9ec6310e7c8163f29f4d47')
+md5sums=('7fec4441d031973710ee61999f964bd2')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
build() {
- cd WWW-Shorten-3.05
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd WWW-Shorten-3.06
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd WWW-Shorten-3.05
- make test
+ cd WWW-Shorten-3.06
+ sanitize
+ make test
}
package() {
- cd WWW-Shorten-3.05
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd WWW-Shorten-3.06
+ sanitize
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}