summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 124439a59ed9..7d560510ad1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,45 @@
# CPAN Name : XML::Compile::SOAP12
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-xml-compile-soap12
-pkgver=3.02
+pkgver=3.03
pkgrel=1
pkgdesc='Perl package that handles SOAP v1.2 protocol'
arch=('any')
-url='http://search.cpan.org/dist/XML-Compile-SOAP12'
+url='https://metacpan.org/release/XML-Compile-SOAP12'
license=('PerlArtistic' 'GPL')
depends=(
'perl-xml-compile>=1.40'
'perl-xml-compile-tester>=0.05'
'perl-xml-compile-cache>=0.995'
- 'perl-xml-compile-soap>=3.04')
+ 'perl-xml-compile-soap>=3.08')
checkdepends=('perl-test-deep>=0.095')
-source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP12-3.02.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP12-3.03.tar.gz)
options=(!emptydirs)
-md5sums=('0a5b398bb35541152e324b4e7b4063f1')
+md5sums=('ec095c530d146104be7e20220414ec85')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
build() {
- cd XML-Compile-SOAP12-3.02
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd XML-Compile-SOAP12-3.03
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd XML-Compile-SOAP12-3.02
+ cd XML-Compile-SOAP12-3.03
+ sanitize
make test
}
package() {
- cd XML-Compile-SOAP12-3.02
+ cd XML-Compile-SOAP12-3.03
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}