summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7d74a949253..d976a73b1977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Generator : CPANPLUS::Dist::Arch 0.16
pkgname='perl-xml-xpathengine'
pkgver='0.14'
-pkgrel=2
+pkgrel=1
pkgdesc="a re-usable XPath engine for DOM-like trees"
arch=('any')
license=('PerlArtistic' 'GPL')
@@ -12,16 +12,20 @@ makedepends=('perl')
url='http://search.cpan.org/dist/XML-XPathEngine'
source=("http://search.cpan.org/CPAN/authors/id/M/MI/MIROD/XML-XPathEngine-$pkgver.tar.gz")
-package() {
+build() {
_DISTDIR="${srcdir}/XML-XPathEngine-$pkgver"
export PERL_MM_USE_DEFAULT=1
- { cd "$_DISTDIR" &&
- perl Makefile.PL INSTALLDIRS=vendor &&
- make &&
- make test &&
- make DESTDIR="${pkgdir}/" install;
- } || return 1;
+ cd "$_DISTDIR"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make test
+}
+package() {
+ _DISTDIR="${srcdir}/XML-XPathEngine-$pkgver"
+ export PERL_MM_USE_DEFAULT=1
+ cd "$_DISTDIR"
+ make DESTDIR="${pkgdir}/" install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}