summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 252ccf19500a..172df4aeeede 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgver=3.20.4
-pkgrel=1
+pkgrel=2
pkgname=petsc
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
@@ -15,7 +15,7 @@ url="https://petsc.org"
license=('BSD')
options=(staticlibs)
# note: zlib is not really needed by PETSc, but netcdf requires an HDF5 version with zlib
-depends=('openmpi' 'lapack' 'hdf5-openmpi' 'fftw' 'superlu' 'suitesparse' 'libyaml' 'gsl' 'libjpeg-turbo' 'netcdf-openmpi' 'zfp' 'zlib'
+depends=('openmpi' 'lapack' 'hdf5-openmpi' 'fftw'-openmpi 'superlu' 'suitesparse' 'libyaml' 'gsl' 'libjpeg-turbo' 'netcdf-openmpi' 'zfp' 'zlib'
'python-numpy' 'python-mpi4py')
makedepends=('gcc' 'gcc-fortran' 'cmake' 'cython')
provides=('petsc4py')
@@ -37,7 +37,7 @@ install=petsc.install
source=(http://web.cels.anl.gov/projects/petsc/download/release-snapshots/${pkgname}-${pkgver}.tar.gz
test_optdepends.sh)
sha512sums=('68abd97377e1e30d3c09afa1617385e8ba56acc8508000c8da47112454462e9da35135076e678cea7a4fa6e46c5b807da3e715b93cb812c4584f2a06df86b951'
- '6950c072271251d1a2d1938a142004042e961cc3d36193c74c9b6eabcf00cb7e0cd7081095b972e8d5b515762d8493aef511e8d7d2691c23c3bdfc6034338c60')
+ 'aef377e84e6bf5aea114f97b1bac8301203e3a6e736cacb49f01a2e95a29022062fc0d9e85fe8ba1ae9bdc1ffa6c007a031327c185e4966d3393adf038fc0993')
_install_dir=/opt/petsc/${_config}
_petsc_arch=arch-${_config}
@@ -90,11 +90,12 @@ build() {
check() {
cd ${srcdir}/${pkgname}-${pkgver}
+ export OMPI_MCA_plm_rsh_agent=sh
if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
+ PYTHONPATH=${srcdir}/tmp/${_install_dir}/lib:${PYTHONPATH} make check
+ else
export OMPI_MCA_opal_warn_on_missing_libcuda=0
fi
- export OMPI_MCA_plm_rsh_agent=sh
- PYTHONPATH=${srcdir}/tmp/${_install_dir}/lib:${PYTHONPATH} make check
}
package() {