summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..886ee2b7f7a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Marco44 (Marc Cousin) <cousinmarc at gmail dot com>
+pkgname=pg_qualstats-git
+_gitname=pg_qualstats
+pkgver=05032a0
+pkgrel=1
+pkgdesc="postgresql background worker to capture data"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/dalibo/pg_qualstats"
+license=('BSD')
+depends=('postgresql')
+builddepends=()
+makedepends=(git)
+options=(!emptydirs !libtool)
+source=('git://github.com/dalibo/pg_qualstats.git')
+md5sums=('SKIP')
+install='pg_qualstats-git.install'
+
+pkgver() {
+ cd $_gitname
+ tag=`git tag | grep REL | tail -1`
+ commit=`git log --format="%h" -n 1`
+ echo "$tag_$commit"
+}
+
+build() {
+ local _gitdir=$srcdir/$_gitname
+ cd $_gitdir
+ git clean -dfx
+ git reset --hard
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname
+ make DESTDIR=$pkgdir install
+}