summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 051c22793bdc..a2cc26f4101e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,16 @@ backup=('etc/pgl/allow.p2p'
'etc/logrotate.d/pglcmd'
'etc/logrotate.d/pgld')
changelog=changelog
-source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/$pkgname-$pkgver.tar.gz")
-sha1sums=('a91c0c49cdbf78aa6cc1d93b8ed6843290460520')
+source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/$pkgname-$pkgver.tar.gz"
+ "pglinux-2.3.1_p20171006-fno-common.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch?id=492d6119594d1774685fcd4f40fb5d754c3d77c4")
+sha1sums=('a91c0c49cdbf78aa6cc1d93b8ed6843290460520'
+ '17b0e89ab5cc9ad9b8ac52823e63f741f5cb6d79')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < ../pglinux-2.3.1_p20171006-fno-common.patch
+}
build() {
cd "$pkgname-$pkgver"