summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cc4d986ce26..736a79802a9c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
# Contributor: Eric Forgeot < http://esclinux.tk >
pkgname=phlipple-svn
-pkgver=0.8.6.r10
-pkgrel=1
+pkgver=0.8.6.r15
+pkgrel=2
pkgdesc="A puzzle game which goal is to reduce a 3D shape to a single square. Elimination of squares is done by flipping edges around just like in a cardboard box."
-arch=("i686" "x86_64")
+arch=("i686" "x86_64" "aarch64")
url="http://sourceforge.net/projects/phlipple/"
-license=('GPLv3')
-depends=('sdl' 'sdl_mixer' 'sdl_image' 'glew' 'libvorbis')
+license=('GPL')
+depends=('mesa' 'sdl' 'sdl_mixer' 'sdl_image' 'glew')
+makedepends=('subversion')
provides=("phlipple")
conflicts=("phlipple")
source=("phlipple::svn://svn.code.sf.net/p/phlipple/code/trunk"
- 'libm.patch')
-md5sums=('SKIP'
- '3bc553faf4501f016ab0dd03307c4547')
+ 'engine.h.patch')
+sha256sums=('SKIP'
+ 'a103d6f139bd246c45f2b62e8f5689eceea3af49521071e1a4f1167053a42a52')
pkgver() {
cd "$srcdir/${pkgname%-*}"
@@ -25,7 +27,7 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-*}"
- patch -Np1 -i "${srcdir}/libm.patch"
+ patch -Np1 -i "${srcdir}/engine.h.patch"
}
build() {