summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 639205774452..f06ef800c199 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phoc
-pkgver=0.9.0
+pkgver=0.11.0
pkgrel=1
pkgdesc='Wlroots based Phone compositor'
url='https://gitlab.gnome.org/World/Phosh/phoc'
@@ -9,7 +9,7 @@ license=(GPL3)
arch=(x86_64 aarch64)
depends=(
mutter
- 'wlroots=0.12.0'
+ wlroots
)
makedepends=(
ctags
@@ -17,21 +17,14 @@ makedepends=(
meson
vala
)
-checkdepends=(xorg-server-xvfb)
source=("${url}/-/archive/v${pkgver}/phoc-v${pkgver}.tar.gz")
-sha256sums=('5fce97ed8fe47ea801d8802136180339c7491d085e1b4b4757eb42ed62e8172d')
+sha256sums=('237ce471bdf01a14259f33725632deceaf429353766205beeb9d96a3fb921de1')
build() {
arch-meson phoc-v${pkgver} build -Dembed-wlroots=disabled
meson compile -C build
}
-check() {
- dbus-run-session xvfb-run \
- -s '-screen 0 1920x1080x24 -nolisten local' \
- meson test -C build --print-errorlogs
-}
-
package() {
DESTDIR="${pkgdir}" meson install -C build
}