summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c9c73f56aba..e7e6bcaf40e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,34 @@
# Merged with official ABS phonon PKGBUILD by João, 2021/05/01 (all respective contributors apply herein)
# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
-pkgbase=phonon-git
-pkgname=(phonon-qt5-git)
+pkgname=phonon-git
pkgdesc="The multimedia framework by KDE"
-pkgver=4.11.1_r3850.g6a5106d3
+pkgver=4.11.1_r3911.g0f0ae8d0
pkgrel=1
arch=($CARCH)
url='https://community.kde.org/Phonon'
license=(LGPL)
-depends=(libpulse qt5-base)
-optdepends=('pulseaudio: PulseAudio support' 'qt5-tools: Designer plugin')
-makedepends=(git extra-cmake-modules-git qt5-tools)
+depends=(libpulse qt6-base)
+optdepends=('pulseaudio: PulseAudio support' 'qt6-tools: Designer plugin')
+makedepends=(git extra-cmake-modules-git qt6-tools qt6-5compat)
conflicts=(${pkgname%-git})
-provides=(${pkgname%-git})
-source=("git+https://github.com/KDE/${pkgbase%-git}.git")
+provides=(${pkgname%-git}{,-qt6})
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
- cd ${pkgbase%-git}
+ cd ${pkgname%-git}
_ver="$(grep -m1 'project(Phonon VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cmake -B build -S ${pkgbase%-git} \
+ cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DBUILD_TESTING=OFF
cmake --build build
}
-package_phonon-qt5-git(){
- depends+=(phonon-qt5-backend)
-
+package() {
DESTDIR="$pkgdir" cmake --install build
}