summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 705e5a4d6af9..bb16164bdba2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh-git
-pkgver=0.7.1.r13.g0ca4ab1
+pkgver=0.12.1.r2.g3e1ba9d
pkgrel=1
-pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
-url="https://source.puri.sm/Librem5/phosh"
-license=("GPL3")
-arch=(i686 x86_64 armv7h aarch64)
+pkgdesc='A pure Wayland shell prototype for GNOME on mobile devices'
+url='https://source.puri.sm/Librem5/phosh'
+license=('GPL3')
+arch=(x86_64 aarch64)
depends=(
- 'feedbackd'
- 'libhandy'
- 'phoc'
+ feedbackd
+ libhandy
+ phoc
)
makedepends=(
- 'ctags'
- 'git'
- 'meson'
- 'vala'
+ ctags
+ git
+ meson
+ vala
)
provides=(phosh)
conflicts=(phosh)
+# checkdepends=(xorg-server-xvfb)
source=(
- "git+https://source.puri.sm/Librem5/phosh.git"
+ "git+${url}.git"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
)
sha256sums=('SKIP' 'SKIP')
@@ -40,7 +41,7 @@ prepare() {
}
build() {
- arch-meson phosh build
+ arch-meson phosh build # -D gtk_doc=true
meson compile -C build
}