summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bfda2bce27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+_pkgname="phosh"
+pkgname="${_pkgname}-git"
+pkgver="latest"
+pkgrel="1"
+pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
+url="https://source.puri.sm/Librem5/${_pkgname}"
+license=("GPL3")
+
+arch=("x86_64")
+depends=("gtk3"
+ "vala"
+ "gnome-desktop"
+ "gobject-introspection"
+ "gtk-doc"
+ "libhandy"
+ "wlroots")
+makedepends=("git"
+ "pkg-config"
+ "meson")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+source=("git+https://source.puri.sm/Librem5/${_pkgname}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ rm -rf build
+ arch-meson "${_pkgname}" build -Dtests=false
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}