summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfa6fc10cbf4..42291ec6c188 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: Carlos Henrique Merces Moreira "chmercesmoreira" <ch.mercesmoreira@gmail.com>
pkgname=photofilmstrip
pkgver=3.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="Create video clips from photos"
arch=('i686' 'x86_64')
url="http://www.photofilmstrip.org/en/"
license=('GPL2')
-depends=('python37' 'python37-pillow' 'python37-wxpython' 'python37-gobject' 'python37-six' 'gst-python')
+depends=('python' 'python-pillow' 'python-wxpython' 'python-sphinx' 'gst-python')
optdepends=('gst-plugins-bad: additional rendering formats'
'gst-plugins-good: additional rendering formats'
'gst-plugins-ugly: additional rendering formats'
@@ -17,16 +17,15 @@ md5sums=('a7b4362b9eb8ede7a4ee99f0165f383a')
build() {
cd "$srcdir/PFS-$pkgver"
- python3.7 setup.py build
+ python setup.py build
}
package () {
cd "$srcdir/PFS-$pkgver"
- python3.7 setup.py install --root="$pkgdir" --optimize=1
+ patch photofilmstrip/action/ActionI18N.py ../../ActionI18N.patch
+ python setup.py install --root="$pkgdir" --optimize=1
chmod 644 "$pkgdir/usr/share/applications/photofilmstrip.desktop"
- mkdir "$pkgdir"/usr/share/doc/photofilmstrip/html
- cp -r ../../*.html "$pkgdir"/usr/share/doc/photofilmstrip/html
find "$pkgdir/usr/share/doc/photofilmstrip/" -type f -exec chmod 644 {} \;
for size in 32x32 48x48 64x64 192x192