summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7587f58ee877..7fd3f55e327c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Contributor: Darko82 <darko 82 (hat) gmail dotcom>
# Maintainer: Joermungand <joermungand at gmail dot com>
pkgname=photoflow-git
-pkgver=r2297.6147363
+pkgver=r2352.ee4b2f45
pkgrel=1
pkgdesc="Non-destructive, layer-based photo retouching including RAW image development"
arch=('i686' 'x86_64')
url="http://aferrero2707.github.io/PhotoFlow"
license=('GPL3')
-depends=('exiv2' 'vips' 'gtkmm' 'pugixml' 'libjpeg-turbo')
+depends=('exiv2' 'vips>=8.5.1' 'gtkmm' 'pugixml' 'libjpeg-turbo')
makedepends=('git' 'gobject-introspection' 'cmake')
provides=('photoflow')
conflicts=('photoflow')
@@ -23,6 +23,7 @@ pkgver() {
build() {
cd ${srcdir}/${pkgname%-*}
+ sed -i 's/-Werror//' src/external/rawspeed/CMakeLists.txt
mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DINSTALL_PREFIX=/usr -DBUNDLED_GEXIV2=OFF ..