summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64709645bb4e..ad8531079b68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Dino Morelli <dino@ui3.info>
pkgname=photoname
-pkgver=3.2
-pkgrel=2
+pkgver=3.3
+pkgrel=1
pkgdesc='Rename JPEG photo files based on shoot date'
-arch=('i686' 'x86_64')
-url="http://hub.darcs.net/dino/photoname"
+arch=('x86_64')
+url="https://github.com/dino-/photoname"
license=('BSD3')
-depends=('gmp' 'libexif' 'libffi')
-makedepends=('ghc' 'stack')
-source=("http://hackage.haskell.org/package/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
+depends=('gmp' 'libexif')
+makedepends=()
+source=("https://github.com/dino-/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-linux.tar.gz")
-sha256sums=('6a4ee3e631d005b6904444d025ec1ccd9aa4dd0e841f4068806567998e86fcf9')
+sha256sums=('e6651cc9f3037ea5c34183a176b2199229c2f6b6023e3ebffe71d3ab6fd4bd4f')
# PKGBUILD functions
package() {
cd ${srcdir}/${pkgname}-${pkgver}
-
- stack runghc -- ./util/install.hs --prefix=${pkgdir}/usr
+ mkdir "${pkgdir}/usr"
+ cp -r * "${pkgdir}/usr"
}