summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad8531079b68..ab37fbc08d65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Dino Morelli <dino@ui3.info>
pkgname=photoname
-pkgver=3.3
+pkgver=4.1
pkgrel=1
pkgdesc='Rename JPEG photo files based on shoot date'
arch=('x86_64')
url="https://github.com/dino-/photoname"
-license=('BSD3')
-depends=('gmp' 'libexif')
+license=('ISC')
+depends=()
makedepends=()
-source=("https://github.com/dino-/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-linux.tar.gz")
+# This software comes as an AppImage, auto-stripping by the AUR tools breaks it
+options=(!strip)
+source=("https://github.com/dino-/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-${CARCH}.AppImage")
-sha256sums=('e6651cc9f3037ea5c34183a176b2199229c2f6b6023e3ebffe71d3ab6fd4bd4f')
+sha256sums=('a736b408be90de1a2b3ea37987bcf52ba787921043bebfd17d5bd3678efb2c2f')
# PKGBUILD functions
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- mkdir "${pkgdir}/usr"
- cp -r * "${pkgdir}/usr"
+ install -m 755 -D "${pkgname}-${pkgver}-${CARCH}.AppImage" "${pkgdir}/usr/bin/${pkgname}"
}