summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 217753a57e29..7fc760eb296a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ url="https://github.com/photoprism/photoprism"
license=('GPLv3')
groups=()
depends=(tensorflow115)
-makedepends=(go nodejs npm)
+makedepends=(go nodejs npm git)
checkdepends=()
optdepends=()
provides=("photoprism")
@@ -23,8 +23,15 @@ backup=("etc/photoprism/options.yml")
options=()
install=
changelog=
-source=("https://github.com/photoprism/photoprism/archive/$pkgver-$commit.tar.gz" "https://dl.photoprism.org/tensorflow/nasnet.zip" "https://dl.photoprism.org/tensorflow/facenet.zip" "https://dl.photoprism.org/tensorflow/nsfw.zip" "photoprism.service" "photoprism.sysusers" "options.yml" "photoprism.tmpfiles")
-sha256sums=('d92064f73ad98c4038e72d4c6b9999473d0c68da4e4ed58a53dfcd553b433b1a'
+source=("git+https://github.com/photoprism/photoprism.git#tag=${pkgver}-${commit}" # "git+https://github.com/photoprism/photoprism.git#commit=$commit"
+ "https://dl.photoprism.org/tensorflow/nasnet.zip"
+ "https://dl.photoprism.org/tensorflow/facenet.zip"
+ "https://dl.photoprism.org/tensorflow/nsfw.zip"
+ "photoprism.service"
+ "photoprism.sysusers"
+ "options.yml"
+ "photoprism.tmpfiles")
+sha256sums=('SKIP'
'a0e1ad8d5a5a0ff9efc4b3ed89898bf008563ee36cacd0c804a384f8fc661588'
'bf9ae0945d2ac53ac3db27082162d2b9dda5ba2c564c0e4c4f539f31f8b670af'
'eb5e5d22e37961c3192a4757efff883f77bc989c0efceabb1395e0959d966f14'
@@ -36,7 +43,7 @@ noextract=()
validpgpkeys=()
build() {
- cd "$pkgname"-"$pkgver"-"$commit"
+ cd "$pkgname"
scripts/build.sh prod ./photoprism
cd "frontend";
@@ -45,7 +52,7 @@ build() {
}
check() {
- "$pkgname"-"$pkgver"-"$commit/photoprism" --version
+ "$pkgname/photoprism" --version
}
package() {
@@ -60,7 +67,7 @@ package() {
cp -r "${srcdir}/nasnet" "${srcdir}/facenet" "${srcdir}/nsfw" "$pkgdir/var/lib/photoprism/assets/"
- cd "$pkgname"-"$pkgver"-"$commit"
+ cd "$pkgname"
install -Dm 0755 ./photoprism "$pkgdir/usr/bin/photoprism"
cp -r assets/locales assets/profiles assets/static assets/templates "$pkgdir/var/lib/photoprism/assets/"