summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2019f812757..939014726daa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Morris Jobke <hey AT morrisjobke DOT de>
pkgname=php-blackfire
pkgver=1.25.0
-pkgrel=1
+pkgrel=2
pkgdesc='Blackfire Profiler - PHP extension'
arch=('i686' 'x86_64')
url='https://blackfire.io'
@@ -10,15 +10,18 @@ license=('custom')
backup=('etc/php/conf.d/blackfire.ini')
depends=('glibc')
+# Change this if you need to support an older version of PHP (think to update the SHA256 sums too)
+PHP_VERSION=73
+
source=('blackfire.ini')
-source_i686=("blackfire.so-${pkgver}_71_i686::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_i386-php-72.so")
-source_x86_64=("blackfire.so-${pkgver}_71_x86_64::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_amd64-php-72.so")
+source_i686=("blackfire.so-${pkgver}_${PHP_VERSION}_i686::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_i386-php-${PHP_VERSION}.so")
+source_x86_64=("blackfire.so-${pkgver}_${PHP_VERSION}_x86_64::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_amd64-php-${PHP_VERSION}.so")
sha256sums=('43f82aea3877cc0133cf2278cb85d0c612cf1f6c869ad430cbaa2b2598f78f33')
-sha256sums_i686=('639fc5ab9640bbd3bf0b6bf36b615d04e7e3bc657537ec0eb7288897fd2476a5')
-sha256sums_x86_64=('e0c1c03915dd5d90642b69ffffad54cdee7490ff0b29fb450d40aab61ef4e485')
+sha256sums_i686=('b46cdaa5bc34a33e2e39d5c26ea1bc90dccdb4352a4edfe3e6937bad900d81e1')
+sha256sums_x86_64=('14e96d8cedc97c611225e0c18abb4350ea010dd0e9dcb167b9784a9e18e6c849')
package(){
install -Dm 644 blackfire.ini "$pkgdir"/etc/php/conf.d/blackfire.ini
- install -Dm 755 blackfire.so-${pkgver}_71_$CARCH "$pkgdir"/usr/lib/php/modules/blackfire.so
+ install -Dm 755 blackfire.so-${pkgver}_${PHP_VERSION}_$CARCH "$pkgdir"/usr/lib/php/modules/blackfire.so
}