summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c30ba1a155f7..a4855bd15a61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Stefan Auditor <stefan.auditor@erdfisch.de>
# Please report issues at https://github.com/sanduhrs/php-humbug-box
-_pkgname='php-humbug-box'
-pkgname="${_pkgname}-bin"
+pkgname=php-humbug-box-bin
pkgver=3.13.0
-pkgrel=1
+pkgrel=2
pkgdesc='Fast, zero config application bundler with PHARs.'
arch=('any')
url='https://github.com/humbug/box'
license=('MIT')
+depends=('php')
provides=('php-box')
conflicts=('php-box')
-install="${_pkgname}.install"
+install=php-humbug-box.install
source=(
- "https://github.com/humbug/box/releases/download/${pkgver}/box.phar"
- "https://raw.githubusercontent.com/humbug/box/${pkgver}/LICENSE"
+ "${pkgname}-${pkgver}.phar::https://github.com/humbug/box/releases/download/${pkgver}/box.phar"
+ "${pkgname}-${pkgver}.LICENSE::https://raw.githubusercontent.com/humbug/box/${pkgver}/LICENSE"
)
-sha512sums=('b593d908d562ce2e0f4cfeaf84cbc6fb315a777550844e381f07ed546640039e7d4e52f0a9cbf66c691cfaac4c43c5ffbcd4b69052bc07718383da4d74b23e14'
+sha512sums=('a1f93271abe7ef53288a605d252c825ee0d7d7065c7b35b46340699b90dc039e05454028c57cc8fdd4907840effb47bcc7839fd88fa1de15916c86ec6bde987b'
'4574410c9a00c41e11d166bcc0d44b4e31b5beaf24bf498a608ebf611e86466a3a61549da6d608b714b3c32c5c361a1514baf38e4db2a5fc0a0d36b69169cb50')
package() {
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
- install -D -m755 "${srcdir}/box.phar" "${pkgdir}/usr/share/webapps/bin/box.phar"
+ install -D -m644 "${pkgname}-${pkgver}.LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${pkgname}-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/box.phar"
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/webapps/bin/box.phar" "${pkgdir}/usr/bin/box"
}