summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1eb8974fa263..afbf90e45ff1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=php-suhosin7-git
_pkgname=${pkgname%-git}
__pkgname=${_pkgname#php-}
pkgver=0.10.0dev.r58.ge55e273
-pkgrel=1
+pkgrel=2
pkgdesc='An advanced protection system for PHP installations'
arch=('i686' 'x86_64')
url='http://suhosin.org/'
@@ -14,22 +14,30 @@ depends=('php')
checkdepends=('php-cgi')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-backup=('etc/php/conf.d/$__pkgname.ini')
-source=("$_pkgname"::"git+https://github.com/sektioneins/$__pkgname.git")
-md5sums=('SKIP')
+backup=("etc/php/conf.d/$__pkgname.ini")
+source=("$_pkgname"::"git+https://github.com/sektioneins/$__pkgname.git"
+ 'php-7.2.patch')
+md5sums=('SKIP'
+ '70da87c05c34e16f6953f27b9cc13e74')
+
+prepare() {
+ cd $_pkgname
+
+ patch -p1 < ../php-7.2.patch
+}
build() {
cd $_pkgname
phpize
- ./configure --prefix=/usr --enable-$__pkgname
+ ./configure --prefix=/usr --enable-$__pkgname --enable-$__pkgname-experimental --enable-static=no
make
}
check() {
cd $_pkgname
- NO_INTERACTION=1 REPORT_EXIT_STATUS=1 make -k test
+ make test NO_INTERACTION=1 REPORT_EXIT_STATUS=1
}
package() {