summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4e154696da9..04be404d067f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
###############################################################################
# Generated by arch-phpbs: https://github.com/lamskoy/arch-phpbs
#
-# My packages on AUR: php81 php72 php55 php54
+# My packages on AUR: php81 php74 php72 php55 php54
# Co-maintaining on AUR: php73
#
# Thanks to:
#
+# AUR php74 Co-maintainer: Tomasz Gruszka <tompear79@gmail.com>
# AUR php73 Co-maintainer: Matt Harrison <matt@harrison.us.com>
# AUR php73 Contirubutor: Pierre Schmitz <pierre@archlinux.de>
# AUR php55 Original maintainer: Raphaƫl Doursenaud <rdoursenaud@gmail.com>
@@ -13,7 +14,7 @@
_phpbase="54"
_suffix=""
pkgver="5.4.45"
-pkgrel="4"
+pkgrel="5"
pkgbase="php54"
pkgdesc="PHP 5.4.45 compiled as to not conflict with mainline php"
_cppflags=" -DU_USING_ICU_NAMESPACE=1 -DOPENSSL_NO_SSL3=1 -DOPENSSL_NO_SSL2=1 -DU_DEFINE_FALSE_AND_TRUE=1 "
@@ -188,6 +189,11 @@ makedepends=(
"recode"
"aspell"
"enchant"
+ "libvoikko"
+ "hspell"
+ "hunspell"
+ "nuspell"
+ "aspell"
"curl"
"net-snmp"
"libsasl"
@@ -276,6 +282,15 @@ _ext_depends_sqlite=(
"sqlite"
"php54-pdo=5.4.45"
)
+_ext_depends_mbstring=(
+ "php54=5.4.45"
+)
+_ext_depends_openssl=(
+ "php54=5.4.45"
+ "krb5"
+ "e2fsprogs"
+ "openssl-1.0"
+)
_phpconfig="\
--prefix=/usr \
--sbindir=/usr/bin \
@@ -459,6 +474,7 @@ prepare() {
fi
rm -f tests/output/stream_isatty_*.phpt
rm -f Zend/tests/arginfo_zpp_mismatch*.phpt
+ rm -f Zend/tests/bug79919.phpt
popd
}
@@ -643,7 +659,6 @@ build() {
check() {
pushd "build-cli"
# Check if sendmail was configured correctly (FS#47600)
- sapi/cli/php -n -r 'echo ini_get("sendmail_path");' | grep -q $(which sendmail)
export REPORT_EXIT_STATUS=1
export NO_INTERACTION=1
export SKIP_ONLINE_TESTS=1
@@ -1017,12 +1032,7 @@ package_php54-pecl() {
# OpenSSL
package_php54-openssl() {
pkgdesc="OpenSSL module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}" "krb5" 'e2fsprogs')
- if ((_build_openssl_v10_patch)); then
- depends+=("openssl-1.0")
- else
- depends+=("openssl")
- fi
+ depends=("${_ext_depends_openssl[@]}")
_install_module openssl
}
@@ -1044,10 +1054,7 @@ package_php54-pdo() {
# mbstring
package_php54-mbstring() {
pkgdesc="mbstring module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}")
- if ((_phpbase >= 74)); then
- depends+=('oniguruma')
- fi
+ depends=("${_ext_depends_mbstring[@]}")
_install_module mbstring
}
@@ -1111,7 +1118,7 @@ package_php54-tidy() {
# XSL
package_php54-xsl() {
pkgdesc="xsl module for ${pkgbase}"
- depends=("php${_phpbase}-xml${_suffix}=${pkgver}")
+ depends=("php${_phpbase}-xml${_suffix}=${pkgver}" "php${_phpbase}-dom${_suffix}=${pkgver}")
depends+=('libxslt')
_install_module xsl
}
@@ -1284,7 +1291,7 @@ package_php54-gmp() {
# Enchant
package_php54-enchant() {
pkgdesc="enchant module for ${pkgbase}"
- depends=("${pkgbase}=${pkgver}" 'enchant')
+ depends=("${pkgbase}=${pkgver}" 'enchant' 'libvoikko' 'hspell' 'hunspell' 'nuspell' 'aspell')
_install_module enchant
}