summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dd37518aa32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+_phpbase=83
+_suffix=
+pkgname="php${_phpbase}-igbinary"
+_pkgname=igbinary
+pkgver=3.2.15
+pkgrel=1
+pkgdesc="php${_phpbase} extension igbinary"
+url="http://pecl.php.net/package/igbinary"
+arch=('x86_64')
+license=('PHP')
+makedepends=("php${_phpbase}${_suffix}")
+depends=("php${_phpbase}${_suffix}")
+backup=("etc/php${_phpbase}/conf.d/${_pkgname}.ini")
+source=("http://pecl.php.net/get/${_pkgname}-${pkgver}.tgz")
+md5sums=('de81e2f54bfbe741a7f2453bccf970e9')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ phpize${_phpbase}
+ ./configure --prefix=/usr CFLAGS="-O2 -g" --enable-igbinary --with-php-config=php-config${_phpbase}
+ make
+}
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ NO_INTERACTION=1 make test
+}
+
+package() {
+ cd "$srcdir/igbinary-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+ install -D -m0644 \
+ "${srcdir}/${_pkgname}-${pkgver}/${_pkgname}.php.ini" \
+ "${pkgdir}/etc/php${_phpbase}/conf.d/${_pkgname}.ini"
+ install -D -m0644 \
+ "${srcdir}/${_pkgname}-${pkgver}/COPYING" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}