summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1ce852fba91..1565193fa88c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,28 @@
_pkgname=phpqa
pkgname=${_pkgname}
-pkgver=0.1.0
+pkgver=0.2.0
pkgrel=1
pkgdesc="PHPQA all-in-one Analyzer CLI tool."
arch=("any")
url="https://github.com/jmolivas/phpqa"
license=("MIT")
depends=("php")
-makedepends=("php-box" "php-composer" "git")
-source=("${_pkgname}"::"git+https://github.com/jmolivas/phpqa.git")
-sha512sums=('SKIP')
-
-pkgver() {
- cd "${_pkgname}"
- git describe --abbrev=0 --tags
-}
+makedepends=("php-composer")
+source=("${pkgname}-${pkgver}"::"https://github.com/jmolivas/phpqa/archive/${pkgver}.tar.gz")
+md5sums=('f2c424045c703d36774e0fd796fb67b2')
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
php /usr/bin/composer install --no-dev
}
package() {
cd "${srcdir}"
+
install -d "${pkgdir}/usr/share/webapps/${_pkgname}"
- cp -r "${_pkgname}" "${pkgdir}/usr/share/webapps/"
+ cp -r "${_pkgname}-${pkgver}" "${pkgdir}/usr/share/webapps/${_pkgname}"
+
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/webapps/${_pkgname}/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}