summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..191beee6fc47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Michael Schubert <mschu.dev at gmail>
+# Contributor: Mick Elliot <micke at sfu dot ca>
+
+pkgname=phyml-mpi
+pkgver=20141029
+pkgrel=1
+pkgdesc='Builds phylogenies from DNA or protein sequences using a maximum likelihood approach, using multiple proccessors'
+arch=('i686' 'x86_64')
+url='https://github.com/stephaneguindon/phyml'
+license=('GPLv2')
+source=("https://github.com/stephaneguindon/phyml-downloads/releases/download/development/phyml-$pkgver.tar.gz")
+sha256sums=('cb1d71107111de8509c4063d2bc1b290f5f2bcb23da136d829bc0450114f5576')
+depends=('openmpi')
+
+build() {
+ cd "${pkgname%-mpi}-$pkgver"
+ aclocal
+ autoreconf --force --install
+ automake --force --add-missing
+ ./configure --prefix=/usr --enable-mpi
+ make
+}
+
+package() {
+ cd "${pkgname%-mpi}-$pkgver"
+ make DESTDIR="$pkgdir" install
+}