summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 16 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e90ced3c4cb..2d14cae8fa37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,35 @@
-# Maintainer: Saiki81 <saikia81 at hotmail dot com>
+# Maintainer: spider-mario <spidermario@free.fr>
+# Contributor: Saiki81 <saikia81 at hotmail dot com>
# adapted from package: pianoteq-stage-trial-bin
# adapted from pkgbuild creator: CrocoDuck <crocoduck dot oducks at gmail dot com>
pkgname=pianoteq-stage
-pkgver=5.8.1
+pkgver=6.1.1
pkgrel=1
pkgdesc="Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions."
arch=('i686' 'x86_64')
-url="https://www.pianoteq.com/pianoteq5"
+url="https://www.pianoteq.com/pianoteq"
license=('LGPL')
depends=('alsa-lib' 'freetype2' 'libxext')
makedepends=('gendesk' 'wget' 'p7zip')
optdepends=()
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}" "pianoteq-stage-bin", "pianoteq-standard-trial-bin")
-source=('https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
-sha256sums=('94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
-
-# Define the target archive filename:
-_pianoteqfilename=pianoteq_stage_linux_v${pkgver//./}.7z
-# Define its checksum:
-_pianoteqsha256sum=ae0100a22432e73c2a7df8890b89239f04d3adc5a6d97440af9517e8e75187af
+# the source package must be downloaded manually
+# this can be done by going to the link here:
+# https://www.pianoteq.com/download?file=pianoteq_stage_linux_v611.7z
+source=("file://pianoteq_stage_linux_v${pkgver//./}.7z"
+ 'https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
+sha512sums=('79b6c8a2066357eafe3c5deef94de10e68b052008cecb8451fcac0e8ec8e8c2d90221c87a558f7940a72c58ea918fe7bb235e4f2ee2c5e3903dc45e470334f8f'
+ '71690cc597b16cd363ddf8837c81eece620be275bf7860e2a2a30cc94da73f32a809d24a086c6ceacbe945282c8b73d03d6567e6058b620b4beb07feb4e46dab')
prepare(){
- # the source package must be downloaded manually
- # this can be done by going to the link here:
- # https://www.pianoteq.com/download?file=pianoteq_stage_linux_v580.7z
- # the checksum will still be validated
- if [ ! -f "../$_pianoteqfilename" ]
- then
- echo "File not found!"
- echo "Pianoteq installation binary file is not found!"
- echo -e "For this package a manual download of the Pianoteq installation binary is needed."
- echo -e "Please go to 'https://www.pianoteq.com/download?file=${_pianoteqfilename}'"
- echo -e "and log in with your user account."
- echo -e "The archive should be in the same directory as the PKGBUILD!"
- exit;
- exit;
- fi
- # move the dependency to ./src/
- mv ../$_pianoteqfilename ./
- # Check integrity:
- echo "$_pianoteqsha256sum $_pianoteqfilename" | sha256sum -c || { echo 'Checksum failed!'; exit 1; }
- # Extract:
- 7z x $_pianoteqfilename
- # Generate Desktop Entry:
- gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='pianoteq 5' --exec='pianoteq\ 5' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
- echo "Note: Try running pianoteq from a shell, if problems occur!"
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='pianoteq 6' --exec='pianoteq\ 6' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
}
package(){
- _pianoteq_type="Pianoteq 5 STAGE"
+ _pianoteq_type="Pianoteq 6 STAGE"
# Define architecture specific file directory:
if [[ "$CARCH" == i686 ]]; then
archdir=i386
@@ -59,11 +37,11 @@ package(){
archdir=amd64
fi
# Install program files:
- install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type" "$pkgdir/usr/bin/pianoteq 5"
- install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.so" "$pkgdir/usr/lib/vst/pianoteq 5.so"
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type" "$pkgdir/usr/bin/pianoteq 6"
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.so" "$pkgdir/usr/lib/vst/pianoteq 6.so"
cd "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.lv2"
for i in *; do
- install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 5.lv2/$i"
+ install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 6.lv2/$i"
done
cd $srcdir
# Install desktop launcher: