summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f8b9cb6e29b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+
+set -u
+pkgname='pico'
+pkgver='2.00'
+pkgrel='1'
+pkgdesc='the real pico text editor from the Alpine Messaging System'
+license=('apache')
+depends=('ncurses')
+makedepends=('gcc')
+arch=('i686' 'x86_64')
+url='http://www.washington.edu/alpine/'
+source=("ftp://ftp.cac.washington.edu/alpine/alpine-${pkgver}.tar.bz2")
+sha256sums=('c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6')
+
+prepare() {
+ set -u
+ cd "${srcdir}/alpine-${pkgver}"
+ # Disabling pam gets the Alpine make farther but then it crashes on a TCP error
+ sed -i -e 's:pam_start:pomme_start:g' 'configure'
+ ./configure --prefix='/usr' --without-ldap --without-ssl --without-krb5 --target 'slx'
+ set +u
+}
+
+build() {
+ set -u
+ cd "${srcdir}/alpine-${pkgver}"
+ make -s c-client
+ make -s c-client.d
+ make -s -j "$(nproc)" -C 'pith'
+ make -s -j "$(nproc)" -C 'pico'
+ # making Alpine crashes on pam errors
+ set +u
+}
+
+package() {
+ set -u
+ cd "${srcdir}/alpine-${pkgver}"
+ make DESTDIR="${pkgdir}" install -C 'pico'
+ rm -f "${pkgdir}/usr/bin"/{pilot,alpine,rpdump,rpload}
+ install -Dpm644 'doc/pico.1' -t "${pkgdir}/usr/share/man/man1/"
+ set +u
+}
+set +u