summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d71935155ec2..81c027f28ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
_pkgname="piglit"
pkgname="${_pkgname}-git"
-pkgver=r9890.827d37435
-pkgrel=2
+pkgver=r10943.cdb765a36
+pkgrel=1
pkgdesc="OpenGL implementation testing suite. Provides a simple means to perform regression tests."
arch=('i686' 'x86_64')
url="http://piglit.freedesktop.org/"
license=('GPL2' 'GPL3' 'LGPL2.1')
-depends=('waffle' 'python-mako' 'python-numpy' 'python-six' 'libxrender' 'glu' 'libcaca' 'libxkbcommon')
+depends=('waffle' 'python-mako' 'python-numpy' 'libxrender' 'glu' 'libcaca' 'libxkbcommon')
optdepends=('python-lxml: Accelerated python XML library using libxml2'
'python-simplejson: Fast implementation of the python JSON library'
- 'python-jsonstreams: A JSON stream writer for python')
-makedepends=('git' 'cmake' 'glproto')
+ 'python-jsonstreams: A JSON stream writer for python'
+ 'vkrunner: Vulkan shader script testing')
+makedepends=('git' 'cmake' 'xorgproto')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
options=('!emptydirs')
install="${_pkgname}.install"
-source=("git://anongit.freedesktop.org/piglit")
+source=("git+https://gitlab.freedesktop.org/mesa/piglit.git")
sha256sums=('SKIP')
pkgver() {
@@ -27,7 +28,10 @@ pkgver() {
build() {
cd "${_pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ .
make
}