summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63e9196d56d1..9a63239a77fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.4.2
+pkgver=1.20
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,26 +11,41 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('8117dc826b853775356de93ece115586')
+b2sums=('a28850c97436d9e445aebcfa9a77a0049a354183228e46b0b3d6e057bcf9292768a8f4406d6a9a3201ab53f5d29e897efba50816850f543d821bd1eace77aaa0')
depends=(
'pyalpm'
'git'
)
+makedepends=(
+ 'python-wheel'
+ 'python-hatchling'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools' # i think it normally should be required by python-pep517 which required by python-build/installer
+ 'python-markdown-it-py'
+)
optdepends=(
- 'asp: for ABS support in -G/--getpkgbuild operation'
+ 'devtools: for Arch Pkgs support in -G/--getpkgbuild operation'
'python-pysocks: for socks5 proxy support'
+ 'python-defusedxml: securely wrap Arch news replies'
+ 'pacman-contrib: to use in pacman hook/systemd timer for cleaning up pikaur cache'
)
conflicts=('pikaur-git')
+provides=('pikaur')
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
- sed -i -e "s/VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
+ sed -i -e "s/^VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
+ if test -d ./dist ; then
+ rm -r ./dist
+ fi
make
+ /usr/bin/python3 -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
- python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ /usr/bin/python3 -m installer --destdir="$pkgdir" dist/*.whl
for langmo in $(cd ./locale && ls ./*.mo); do
lang=$(sed -e 's/.mo$//' <<< "${langmo}")
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"