summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cc7de2f4c7a..ffaaec05864d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=0.15.1
+pkgver=1.0
pkgrel=1
pkgdesc="AUR helper with minimal dependencies inspired by pacaur, yaourt and yay. Review PKGBUILDs all in once, next build them all without user interaction."
arch=('any')
@@ -11,12 +11,15 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('0dde489da70e25a8cd1cc3eeb6662c3c')
+md5sums=('4b75fd3193e2b71822d058500d42229c')
depends=(
- 'pacman>=5.1'
+ 'pacman'
'pyalpm'
'git'
)
+makedepends=(
+ 'ruby-ronn'
+)
conflicts=('pikaur-git')
build() {
@@ -33,5 +36,6 @@ package() {
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"
done
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 pikaur.1 "$pkgdir/usr/share/man/man1/pikaur.1"
cp -r ./packaging/* "${pkgdir}"
}