summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa0ae9ba864c..63e9196d56d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,13 +11,14 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('c1c476894d1a9e994256dbb0f0c6ebe0')
+md5sums=('8117dc826b853775356de93ece115586')
depends=(
'pyalpm'
'git'
)
optdepends=(
'asp: for ABS support in -G/--getpkgbuild operation'
+ 'python-pysocks: for socks5 proxy support'
)
conflicts=('pikaur-git')
@@ -29,7 +30,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
for langmo in $(cd ./locale && ls ./*.mo); do
lang=$(sed -e 's/.mo$//' <<< "${langmo}")
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"