summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2697bbb0b565
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Parker Reed <parker.l.reed@gmail.com>
+# Maintainer: dale <dale@archlinux.org>
+
+pkgname=pilot-link
+pkgver=0.12.5
+pkgrel=1
+pkgdesc="A suite of tools for connecting to PalmOS handheld devices"
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL')
+depends=('readline>=6.0' 'libpng>=1.4.0' 'libusb-compat' 'popt' 'bluez>=4.59')
+options=('!libtool')
+url=http://www.pilot-link.org/
+source=(http://pkgs.fedoraproject.org/repo/pkgs/pilot-link/pilot-link-0.12.5.tar.bz2/568c55bf504b044f6fbd50baa407c990/$pkgname-$pkgver.tar.bz2
+ pilot-link-png14.patch)
+md5sums=('568c55bf504b044f6fbd50baa407c990'
+ 'a21a2eeb01544a8a261a75e64a3120c3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/pilot-link-png14.patch"
+ ./configure --prefix=/usr --enable-conduits --enable-libusb \
+ --with-libiconv --with-libpng
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}