summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d497a332a23..0dedba21eb05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Fabio Rämi <fabio at dynamix-tontechnik dot ch>
pkgname=pinball-unofficial
_realname=pinball
-pkgver=0.3.3
+pkgver=0.3.3.3
pkgrel=1
-pkgdesc="The Emilia Pinball Project Unofficial version 0.3.2 with 2 new tables"
+pkgdesc="The Emilia Pinball Project unofficial version with 2 new tables"
arch=('i686' 'x86_64')
-url="https://github.com/sergiomb2/pinball.old"
+url="https://github.com/sergiomb2/pinball"
license=('GPL2')
-depends=('sh' 'sdl_mixer' 'sdl_image' 'mesa' 'gcc-libs')
+depends=('sdl_mixer' 'sdl_image' 'mesa' 'gcc-libs')
provides=('pinball=0.3.1')
conflicts=('pinball')
options=('!makeflags' 'libtool')
-source=("https://github.com/sergiomb2/${_realname}.old/archive/${pkgver}.tar.gz")
-sha512sums=('7bdadf505774b694da16ad9fb34e76ac32c888cf482068b19caa7c616fe456bf705366d7737d24f346ab064a4ff6e9fc4b98fe14be9699479ca3ff8a0d127cde')
+source=("https://github.com/sergiomb2/${_realname}/archive/${pkgver}.tar.gz")
+sha512sums=('697ab9a66bb559c54cb43f926e1aadb36fe74cdccf69bb5e248aeeecdf48fc8ccee67655ef44fb43f5c1819946faf68e6754012b782a2a189394d0b2275a7545')
build() {
- cd "${srcdir}/${_realname}.old-${pkgver}"
+ cd "${srcdir}/${_realname}-${pkgver}"
autoreconf -i
+ ./bootstrap
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/${_realname}.old-${pkgver}"
+ cd "${srcdir}/${_realname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+ make clean
install -d ${pkgdir}/usr/share/applications
install -m644 -t ${pkgdir}/usr/share/applications/ ${_realname}.desktop
}