summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23fe9464e961..742bbe2ca84b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=pipgrip
-pkgver=0.7.2
+pkgver=0.8.0
pkgrel=1
pkgdesc="Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm"
arch=('any')
@@ -10,7 +10,14 @@ depends=('python-anytree' 'python-click' 'python-pip' 'python-packaging' 'python
'python-setuptools' 'python-wheel')
makedepends=('python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('e7f2ef078b1db1ebb0abf31adc34d77061ed73102257c99acba12ca15f98ecd1')
+sha256sums=('2ecf32bc30d245145de5ae0f4ea6b7e3e1ae2deff7b6317931a4a470185560d4')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # Relax pkginfo requirement
+ find . -type f -exec sed -i 's|pkginfo>=1.4.2,<1.8|pkginfo>=1.4.2|g' {} \;
+}
build() {
cd "$pkgname-$pkgver"