summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20bfdf573b38..31db100b6bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
# Contributor: Matthew Bauer <mjbauer95@gmail.com>
# Contributor: TingPing <tingping@fedoraproject.org>
# Contributor: Christopher Eby <kreed@kreed.org>
-# Maintainer: Steven Allen <steven@stebalien.com>
+# Contributor: Steven Allen <steven@stebalien.com>
pkgname=pithos
-pkgver=1.4.0
-pkgrel=1
+pkgver=1.6.2
+pkgrel=2
pkgdesc='Native Pandora Radio client'
-arch=('any')
+arch=(any)
url="https://pithos.github.io/"
-license=('GPL3')
-depends=('gtk3' 'python-gobject' 'libsecret' 'python-cairo'
+license=(GPL-3.0-only)
+depends=('gtk3' 'python-gobject' 'libsecret' 'python-cairo' 'pango'
+ 'python' 'dconf' 'gdk-pixbuf2' 'hicolor-icon-theme'
'gst-plugins-good' 'gst-libav' 'gst-plugins-base')
optdepends=('libkeybinder3: for media keys plugin'
- 'libappindicator-gtk3: Unity indicator applet support'
'python-pacparser: PAC proxy support'
'python-pylast: Last.fm scrobbling support'
'python-systemd: Logging to the system journal')
makedepends=('meson' 'appstream-glib')
source=(
- "https://github.com/pithos/pithos/releases/download/${pkgver}/pithos-${pkgver}.tar.xz"{,.asc}
- "dbus.service"
+ "pithos-${pkgver}.tar.gz::https://github.com/pithos/pithos/archive/refs/tags/${pkgver}.tar.gz"
"systemd.service"
)
-sha256sums=('4c025d7e1e055292849b80c37d8ad3862e0f2cbd9c7327664deb8ac0389952ac'
- 'SKIP'
- '2b80c9bb84f7de8de0e36dc16465c6633cb74de7bf777efcad76393e88a6e62a'
+sha256sums=('69fffb5af07787eaf603d9e63b6facf25cc41760109dee5a92514354edd1068d'
'6d29178697384fb046d9d25c6c2482f353a4484ec4f0a5b9080d1a26aa24f839')
-validpgpkeys=('108BF2212A051F4A72B18448B3C7CE210DE76DFC')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ echo "SystemdService=pithos.service" >> "data/io.github.Pithos.service.in"
+}
build() {
cd "${srcdir}"
@@ -42,6 +42,5 @@ build() {
package() {
cd "${srcdir}/build"
DESTDIR="${pkgdir}" ninja install
- install -Dm644 "${srcdir}/dbus.service" "${pkgdir}/usr/share/dbus-1/services/io.github.Pithos.service"
install -Dm644 "${srcdir}/systemd.service" "${pkgdir}/usr/lib/systemd/user/pithos.service"
}