summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c21c82fbf6d9..7589f211f759 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Maintainer: Steven Allen <steven@stebalien.com>
pkgname=pithos
-pkgver=1.2.1
-pkgrel=3
+pkgver=1.3.0
+pkgrel=1
pkgdesc='Native Pandora Radio client'
arch=('any')
url="https://pithos.github.io/"
@@ -18,8 +18,20 @@ optdepends=('libkeybinder3: for media keys plugin'
'python-pylast: Last.fm scrobbling support'
'libnotify: Notification support')
makedepends=('intltool')
-source=("https://github.com/pithos/pithos/releases/download/${pkgver}/pithos-${pkgver}.tar.xz")
-sha256sums=('51dc6095162df3ee095a34d3a9ab20aeb4c99fe017a48ae648a5dd55d21c2c17')
+source=(
+ "https://github.com/pithos/pithos/releases/download/${pkgver}/pithos-${pkgver}.tar.xz"{,.asc}
+ 'fix-python36.patch::https://github.com/pithos/pithos/commit/be9e8cb35692ef0b7d835dc26b28996cf6aacb7b.patch'
+)
+sha256sums=('9ff5ae0aac3265cd8ba91d07f42ec0819d6909d9607e4f6c10188ff3645134a9'
+ 'SKIP'
+ 'e39a4d5ff114dcb30ffef5b927b757a09d025d73025d8c5d9043a7b9baa1ef07')
+
+validpgpkeys=('108BF2212A051F4A72B18448B3C7CE210DE76DFC')
+
+prepare() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ patch -Np1 -i "$srcdir/fix-python36.patch"
+}
build() {
cd "$srcdir/${pkgname}-$pkgver"