summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 999a7138ea14..3e3d988d1715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Wilson <alex at cooperi dot net>
pkgname=pivy
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption"
url="https://github.com/arekinath/pivy"
license=('MPL2')
@@ -9,16 +9,18 @@ source=(
"zfs-pivy.hook"
"zfs-pivy.install"
"https://github.com/arekinath/pivy/archive/v$pkgver.tar.gz"
- "https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz")
+ "https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz"
+ "https://github.com/arekinath/mini-pcsc/archive/v0.1.0.tar.gz")
arch=(x86 x86_64)
depends=(libbsd pcsclite libedit)
optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
'zfs-utils: ZFS encrypted pool/fs support (pivy-zfs)')
makedepends=(pkgconf cryptsetup zfs-utils json-c)
-md5sums=('d93eb0df79e3700e316903eefc13b669'
- '682ea42ea2f4ea193e72c7ec332782a7'
- '15fc9fbdf780d05e093474a9a7faec23'
- '94ce8f4cdbb6b57565da61e380d63045')
+sha256sums=('404e1ba4ab21e030f1661898d21c6a64a7dda5ad12cee678e33ad77856557f1b'
+ '44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678'
+ 'f29ae879030bcd72a04df71b1854d1cf9ecda130825efc80ab7fe3b74d3735b8'
+ '1e3a9fada06c1c060011470ad0ff960de28f9a0515277d7336f7e09362517da6'
+ 'aff68661c77bde91d67bfe3a132fab1bfa6e445281c7362caa59e5238b228e66')
prepare() {
mv "libressl-2.7.4" "$pkgname-$pkgver/libressl"
@@ -27,12 +29,18 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
make prefix=/usr USE_ZFS=yes USE_LUKS=yes
+ cd "../mini-pcsc-0.1.0"
+ make
}
package() {
cd "$pkgname-$pkgver"
make prefix=/usr DESTDIR="$pkgdir/" USE_ZFS=yes USE_LUKS=yes install
+ cd "../mini-pcsc-0.1.0"
+ install -o root -g root -m 0755 -d "${pkgdir}/usr/lib"
+ install -o root -g root -m 0755 libminipcsc.so "${pkgdir}/usr/lib/libminipcsc.so"
+
cd "$srcdir"
hookdir="${pkgdir}/usr/lib/initcpio/hooks"
hookinsdir="${pkgdir}/usr/lib/initcpio/install"