summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3761e3f93673..a2d615d54c2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,29 @@
# Contributor: Hilton Medeiros <medeiros.hilton@gmail.com>
pkgname=pixelorama
-pkgver=0.8.2
+pkgver=0.11.3
pkgrel=1
pkgdesc="A free & open-source 2D sprite editor"
-arch=('i686' 'pentium4' 'x86_64')
+arch=('x86_64')
url="https://orama-interactive.itch.io/pixelorama"
_url="https://github.com/Orama-Interactive/Pixelorama"
license=('MIT')
-depends=('alsa-lib' 'hicolor-icon-theme' 'libglvnd' 'libpulse' 'libxcursor' 'libxinerama' 'libxrandr')
+depends=('hicolor-icon-theme' 'libglvnd' 'libxcursor' 'libxi' 'libxinerama' 'libxrandr')
makedepends=('curl' 'godot' 'unzip')
provides=('pixelorama')
-conflicts=('pixelorama-bin' 'pixelorama-git')
source=("${pkgname^}-${pkgver}.tar.gz::${_url}/archive/v${pkgver}.tar.gz")
-sha512sums=('b150895e0c869d2fb91b30edd6ab3920d14dcad28e23464cf5e0d2cfa1b7e7e462f0706463c266acf19a9461fb836b8844bacacd829b732b35d54473931476bf')
+b2sums=('c5c9e584f89bd7cfe28540c30b8214dd9fd4a87fd946e225238ef93a154d43108ad63af8aa139aec862db83da3bfeccc052c048b7aedc1a9b3a89bb7d5d46576')
prepare() {
# Checks if the user's directory has the export templates
# and downloads them, if necessary
# Get Godot Engine version
- _godot_bin=$(which godot)
- _godot_version_full_string=$(strings ${_godot_bin} | grep "Godot Engine v" | sed 's/.*\ v//' | sed 's/\ .*//' | head -1)
+ _godot_version_full_string=$(godot --version)
_godot_version=${_godot_version_full_string%.*}
_godot_version_number=$(echo ${_godot_version} | sed 's/\.[[:alpha:]].*//')
- _templates_home_dir=~/.local/share/godot/templates/${_godot_version}
+ _templates_home_dir=~/.local/share/godot/export_templates/${_godot_version}
if [ ! -d ${_templates_home_dir} ]
then
@@ -51,17 +49,17 @@ prepare() {
rmdir templates
fi
- sed -i "s/enable_file_logging=true/enable_file_logging=false/" \
+ sed -i "/enable_file_logging/ s/true/false/" \
"${srcdir}/${pkgname^}-${pkgver}/project.godot"
- echo "#!/bin/sh" >> "${srcdir}/${pkgname^}-${pkgver}/Misc/Linux/${pkgname}.sh"
+ echo '#!/bin/sh' > "${srcdir}/${pkgname^}-${pkgver}/Misc/Linux/${pkgname}.sh"
echo "exec /usr/lib/${pkgname}/${pkgname} \"\$@\"" >> "${srcdir}/${pkgname^}-${pkgver}/Misc/Linux/${pkgname}.sh"
}
build() {
cd "${srcdir}/${pkgname^}-${pkgver}"
mkdir -p build
- godot --export "Linux/X11 $(getconf LONG_BIT)-bit" --path . project.godot build/${pkgname}
+ godot --export-release "Linux/X11 $(getconf LONG_BIT)-bit" --display-driver headless --path . project.godot build/${pkgname}
}
package() {