summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb736c2d6a03..de97c383d893 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pkgbuild-introspection-git
_pkgname=pkgbuild-introspection
-pkgver=6.4.ga135f86
+pkgver=9
pkgrel=1
pkgdesc='Tools for generating .SRCINFO files and PKGBUILD data extraction (mkaurball)'
url="https://github.com/falconindy/$_pkgname"
@@ -10,6 +10,7 @@ license=('MIT')
arch=('any')
depends=('bash' 'pacman')
makedepends=('git')
+checkdepends=('python-srcinfo')
provides=('pkgbuild-introspection')
conflicts=('pkgbuild-reflection-git' 'pkgbuild-introspection')
source=("git://github.com/falconindy/$_pkgname.git")
@@ -27,6 +28,12 @@ build() {
make
}
+check() {
+ cd "$_pkgname"
+
+ make check
+}
+
package() {
cd "$_pkgname"