summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e919a41595b..8d5d976a7cd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
# https://github.com/orhun/pkgbuilds
pkgname=pkgtop-git
-pkgdesc="Interactive package manager & resource monitor"
+pkgdesc="Interactive package manager & resource monitor (git)"
pkgver=2.4.r0.g639b2fe
pkgrel=1
arch=('x86_64')
url="https://github.com/orhun/pkgtop"
license=('GPL3')
makedepends=('git' 'go')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
source=("git+$url")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}/src"
+ cd "${pkgname%-git}/src"
go get -d ./...
go build \
-gcflags "all=-trimpath=$PWD" \
@@ -28,7 +30,7 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}/src"
+ cd "${pkgname%-git}/src"
install -Dm 755 "${pkgname%-git}" -t "$pkgdir/usr/bin"
install -Dm 644 "../README.md" -t "$pkgdir/usr/share/doc/${pkgname%-git}"
-} \ No newline at end of file
+}