summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 12 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4afd02dc036..6d27270a5ffc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,37 @@
# Contributor: fancris3 <fancris3 at aol.com>
pkgname=e17-places-svn
+_pkgname=places
pkgver=82790
pkgrel=1
-pkgdesc="Enlightenment e17 module: Manage the mounting of volumes"
+pkgdesc="Enlightenment module: Manage the mounting of volumes"
arch=('i686' 'x86_64')
url="http://code.google.com/p/e17mods/wiki/Places"
license=('BSD')
depends=('enlightenment17' 'e_dbus')
makedepends=('subversion')
-provides=('e17-places')
+conflicts=('e-modules-extra')
options=('!libtool')
+source=("svn+http://svn.enlightenment.org/svn/e/trunk/E-MODULES-EXTRA/$_pkgname")
+md5sums=('SKIP')
-_svntrunk=http://svn.enlightenment.org/svn/e/trunk/E-MODULES-EXTRA/places
-_svnmod=places
+pkgver() {
+ svnversion "$SRCDEST/$_pkgname"
+}
build() {
- cd "$srcdir"
-
- msg "Connecting to SVN server...."
-
- if [[ -d "$_svnmod/.svn" ]]; then
- (cd "$_svnmod" && svn up -r "$pkgver")
- else
- svn co "$_svntrunk" --config-dir ./ -r "$pkgver" "$_svnmod"
- fi
-
- msg "SVN checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_svnmod-build"
- svn export "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
- cd "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_pkgname"
./autogen.sh --prefix=/usr
+
make
}
package() {
- cd "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_pkgname"
+
make DESTDIR="$pkgdir" install
# install license files
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
-
- rm -r "$srcdir/$_svnmod-build"
}