summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 913a6a8f7fbe..4a1f2ec22c77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,30 @@
# Contributor: George Rawlinson
pkgname=plasma5-applets-plasma-pass-git
-pkgver=r16.d067ec5
-pkgrel=3
+pkgver=r30.f0ffe06
+pkgrel=1
pkgdesc='Plasma applet for pass.'
url="https://cgit.kde.org/scratch/dvratil/plasma-pass.git"
arch=('x86_64' 'i686')
license=('GPL2')
-depends=('pass' 'plasma-framework')
+depends=('pass' 'plasma-framework' 'kitemmodels')
makedepends=('extra-cmake-modules' 'git')
provides=('plasma5-applets-plasma-pass')
source=("git+https://anongit.kde.org/scratch/dvratil/plasma-pass.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/plasma-pass"
+ cd plasma-pass
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/plasma-pass"
- [ -d build ] && rm -Rf build
- mkdir -p build
- cd build
+ mkdir -p plasma-pass/build
+ cd plasma-pass/build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
}
package(){
- cd "${srcdir}/plasma-pass/build"
+ cd plasma-pass/build
make DESTDIR="$pkgdir" install
}