summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9681d82b6cb..9b1646e6cd5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_github_pkgname=PlayBar2
pkgname=plasma5-applets-playbar2
pkgver=2.5
-pkgrel=2
+pkgrel=3
pkgdesc="Applet that shows now playing music"
arch=('i686' 'x86_64')
url="https://github.com/audoban/PlayBar2/"
@@ -21,13 +21,18 @@ conflicts=(
)
source=("https://github.com/audoban/$_github_pkgname/archive/v${pkgver}.tar.gz")
-sha512sums=(367984610621daecc2e1389d4d30284bdd6cc2842ee81f4638cc14863f449e811d6351ffb8832f5c95e2bb007c6d7c88e7d80f7744d01723527ddc5c6c785c96)
+sha512sums=('367984610621daecc2e1389d4d30284bdd6cc2842ee81f4638cc14863f449e811d6351ffb8832f5c95e2bb007c6d7c88e7d80f7744d01723527ddc5c6c785c96')
+prepare() {
+ cd "$srcdir/$_github_pkgname-$pkgver"
+
+ mkdir -p build
+}
build() {
cd "$srcdir/$_github_pkgname-$pkgver"
- mkdir -p build && cd build
+ cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
}