summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5dd846b105b..a445cc239fa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,47 @@
# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
-_pkgname=uswitch
pkgname=plasma5-applets-uswitch
-pkgver=1.2.2
+pkgver=1.3.0
pkgrel=1
pkgdesc='Modified version of User Switch plasmoid'
-url="https://gitlab.kokakiwi.net/contrib/kde/plasma-addons/uswitch"
+url='https://gitlab.com/divinae/uswitch'
license=('GPL3')
arch=('any')
depends=('plasma-workspace')
-makedepends=('git' 'cmake' 'extra-cmake-modules')
+makedepends=('git' 'cmake' 'extra-cmake-modules' 'kcoreaddons')
provides=('plasma5-applets-uswitch')
conflicts=('plasma5-applets-uswitch')
-source=("$_pkgname-$pkgver.tar.gz::https://gitlab.kokakiwi.net/contrib/kde/plasma-addons/$_pkgname/-/archive/v$pkgver/$_pkgname-v$pkgver.tar.gz")
-sha256sums=('c5c4b83ce4b0ffc3feacb8189f800eb5d7af2490a99ba9bbfc7465b81a2c38e0')
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/divinae/uswitch/-/archive/$pkgver/uswitch-$pkgver.tar.gz")
+sha256sums=('e861467b1161b2080d05bd4af764c0d4d956c7501c148c4a1f9a7a05e14d18f9')
+b2sums=('0ea0accc84c999b814c6e31c81fe5021c1db423694324cd08ce1a52827d58bd306cc73d10df1c720124b1d89555261bed2250efe4f6d34187f03f2c723555faf')
+
+prepare() {
+ cd "uswitch-$pkgver"
+
+ cd package
+ desktoptojson -i metadata.desktop
+
+ mkdir -p plasmoid
+ mv -t plasmoid metadata.json contents
+}
build() {
- cd "$_pkgname-v$pkgver"
+ cd "uswitch-$pkgver"
cmake -S package -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=RelWithDeb \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ -W no-dev \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=RelWithDeb \
+ -D KDE_INSTALL_LIBDIR=lib \
+ -D KDE_INSTALL_USE_QT_SYS_PATHS=ON
cmake --build build
}
package() {
- cd "$_pkgname-v$pkgver"
+ cd "uswitch-$pkgver"
cmake --install build --prefix "${pkgdir}/usr"
+
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}