summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cb5ffdd8a08..5c7e48b4af92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,24 +8,25 @@
#
pkgname=platformio
-pkgver=4.0.2
+pkgver=4.2.0
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="https://github.com/platformio/platformio-core/"
license=('Apache')
-depends=('python-bottle'
+depends=('python-setuptools'
+ 'python-bottle'
'python-click'
'python-colorama'
- 'python-lockfile'
'python-pyserial>=3.4' #https://github.com/platformio/platformio-core/commit/a37eb9868f3b20e982d0c3cd1a742fcb8ab60efc
'python-requests'
'python-semantic-version'
- 'python-setuptools'
- 'python-tabulate')
+ 'python-tabulate'
+ 'python-pyelftools'
+ 'python-marshmallow')
conflicts=('platformio-git')
source=("https://github.com/platformio/platformio-core/archive/v${pkgver}.tar.gz")
-sha256sums=('1fb3dcdf31b71896eeaa04cd113135274ef630219ab4f692a6bde7b3ca98cc70')
+sha256sums=('ae60d49ab6ac4c07d46196c30119339ae16f0e3c792c51376fdd12faa6204b48')
package() {
cd "$srcdir/platformio-core-$pkgver"