summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 32 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15bb86921bb1..c29661342825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,44 @@
pkgname=platformio-git
_pkgname=platformio-core
-pkgver=v4.3.4.r85.g7bc22353
+pkgver=v6.1.11.r20.gb238c55e
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="http://platformio.org/"
license=('GPL')
provides=('platformio')
-depends=('python-setuptools'
- 'python-bottle'
- 'python-click'
- 'python-colorama'
- 'python-pyserial'
- 'python-requests'
- 'python-semantic-version'
- 'python-tabulate'
- 'python-pyelftools'
- 'python-marshmallow')
+depends=(
+ 'python'
+ 'python-bottle'
+ 'python-click'
+ 'python-colorama'
+ 'python-pyserial'
+ 'python-requests'
+ 'python-semantic-version'
+ 'python-tabulate'
+ 'python-pyelftools'
+ 'python-marshmallow'
+ 'python-zeroconf'
+ 'python-aiofiles'
+ 'python-ajsonrpc'
+ 'python-starlette'
+ 'python-wsproto'
+ 'uvicorn'
+)
optdepends=('energia: For MSP430 based projects'
- 'arduino: For Arduino based projects')
-makedepends=('git')
+ 'arduino: For Arduino based projects'
+ 'platformio-core-udev: Udev rules for PlatformIO supported boards/devices'
+ 'python-click-completion: for shell completions'
+ 'python-shellingham: for shell completions'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
source=('git+https://github.com/platformio/platformio-core.git')
md5sums=('SKIP')
@@ -42,6 +60,6 @@ package() {
cd "${srcdir}/${_pkgname}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
- install -Dm644 "${srcdir}/${_pkgname}/scripts/99-platformio-udev.rules" \
+ install -Dm644 "${srcdir}/${_pkgname}/build/lib/platformio/assets/system/99-platformio-udev.rules" \
"${pkgdir}/etc/udev/rules.d/99-platformio-udev.rules"
}