summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55e3cd5ae523
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Fabio Manganiello <info@fabiomanganiello.com>
+
+pkgname=platypush
+pkgver=0.12.10
+pkgrel=1
+pkgdesc="Universal multi-platform command executor and automation manager"
+arch=('any')
+license=('MIT')
+url="https://github.com/BlackLight/platypush"
+depends=('python' 'python-yaml' 'redis' 'python-redis' 'python-requests' 'python-sqlalchemy' 'python-websockets' 'python-websocket-client' 'python-wheel' 'python-flask'
+ 'python-pip' 'python-dateutil' 'python-frozendict' 'python-bcrypt')
+optdepends=('python-paho-mqtt: MQTT integrations support'
+ 'python-pybluez: Bluetooth support'
+ 'gattlib: Low-energy Bluetooth devices support'
+ 'python-paramiko: SSH support'
+ 'python-croniter: Platypush cron support'
+ 'python-pyserial: Arduino/serial device support')
+options=(!strip)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/BlackLight/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('9e9c0c2450695c0f6fb00cdeb54c02fa952dca74544be40134cd6b78c994beadc223b1ae59952bb88d155fe265caa3a9ba554852f09a04e85c3cb99a754bb456')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python3 setup.py build install --root="${pkgdir}/" --optimize=1
+
+ install -m755 -d "${pkgdir}/usr/lib/systemd/user"
+ install -m644 "${srcdir}/${pkgname}-${pkgver}/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"
+
+ echo
+ echo
+ echo ---------------------------------------------
+ echo You can start the Platypush service through
+ echo systemctl --user start platypush.
+ echo
+ echo Remember to enable/start the Redis service
+ echo before starting Platypush.
+ echo ---------------------------------------------
+ echo
+ echo
+}
+