summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..423eff4dfc3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Christopher Vittal <christopher dot vittal at gmail dot com>
+_pkgname='plink1.9'
+pkgname="$_pkgname-git"
+_pkgver=1.9
+pkgver=1.9.r191.g927247b5
+pkgrel=1
+pkgdesc="whole-genome association analysis toolset, version 1.9"
+arch=(x86_64)
+license=(GPL3)
+url="https://www.cog-genomics.org/plink/1.9/"
+source=('plink1.9::git+https://github.com/chrchang/plink-ng.git'
+ 'bin-name.patch')
+depends=('zlib>=1.2.4' 'cblas' 'lapack')
+sha256sums=(SKIP
+ 6d489d96f1c9f055dd5858ca3618db34d47adcb5f1eba2a12ad699ff787028ac)
+
+prepare() {
+ cd "$_pkgname/$_pkgver"
+ patch -i "${srcdir}/bin-name.patch"
+}
+
+build() {
+ cd "$_pkgname/$_pkgver"
+ CFLAGS+=' -DDYNAMIC_ZLIB' CXXFLAGS+=' -DDYNAMIC_ZLIB' \
+ BLASFLAGS=$(pkg-config --libs lapack blas cblas) ZLIB=-lz \
+ LDFLAGS+=' -lpthread -lm' BIN=$_pkgname make -f Makefile.std
+}
+
+package() {
+ cd "$_pkgname/$_pkgver"
+ BIN="$_pkgname" DESTDIR="$pkgdir" PREFIX=/usr make -f Makefile.std install
+}
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$_pkgver"."$(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^.*\.r/r/')"
+}